summaryrefslogtreecommitdiff
path: root/dev-python/tinyhtml5
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tinyhtml5')
-rw-r--r--dev-python/tinyhtml5/Manifest3
-rw-r--r--dev-python/tinyhtml5/metadata.xml12
-rw-r--r--dev-python/tinyhtml5/tinyhtml5-2.0.0.ebuild26
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/tinyhtml5/Manifest b/dev-python/tinyhtml5/Manifest
new file mode 100644
index 000000000000..926e9c1ae611
--- /dev/null
+++ b/dev-python/tinyhtml5/Manifest
@@ -0,0 +1,3 @@
+DIST tinyhtml5-2.0.0.tar.gz 179507 BLAKE2B 600e4852c49649c77d060114bb412b0cd0cf85c64d627ec4796bbce167605ff5fa15fc11504f8bf170bbce4ab7adbdc76b2f4291971b28b6a30054dab5e4efe5 SHA512 79b78171d021a0cd7f6f56b2e5bd0d9bab422cbec4c601e19cb9c248eac0df74339290f0aaacc12eae4f733e92743a0a24e8caddf709f3bc86f3c022c4df3ded
+EBUILD tinyhtml5-2.0.0.ebuild 554 BLAKE2B 9c5c80c95fc43f5d17388857ffe56ace9f02c4a15ed9de49ce805986e27558e16d80affd47fda731b55c7d347c8b84d1c98441618cb52a6cc0cba001ce628193 SHA512 965f617020c94d7170e8bcf5d0d6178d913eaa6629a593976461b90d0a83fa300a7c080c87b6cbefd1aad042dca743d14a6d53bc6f6d71950b2a8347e81d5c79
+MISC metadata.xml 378 BLAKE2B 122fdb35720ec666b0e02f21f7e19bc07330946b82429ea56947d40c7912e251479e7a5c5b4857835566f8ac4ef897640dfbc79ae48a10f08c8253dcfd807df9 SHA512 3783aa245ad8dfe297396f4d79238f63c005f7a8d89bba30f14d3908bd65766b7f3322e7f072533c9b3743bab6eb5b5deeca94c2b3fd24ba04026af1cc0031e1
diff --git a/dev-python/tinyhtml5/metadata.xml b/dev-python/tinyhtml5/metadata.xml
new file mode 100644
index 000000000000..a2004a01dc6d
--- /dev/null
+++ b/dev-python/tinyhtml5/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">CourtBouillon/tinyhtml5</remote-id>
+ <remote-id type="pypi">tinyhtml5</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tinyhtml5/tinyhtml5-2.0.0.ebuild b/dev-python/tinyhtml5/tinyhtml5-2.0.0.ebuild
new file mode 100644
index 000000000000..0d90c411acd2
--- /dev/null
+++ b/dev-python/tinyhtml5/tinyhtml5-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTML parser based on the WHATWG HTML specification"
+HOMEPAGE="
+ https://doc.courtbouillon.org/tinyhtml5/latest/
+ https://github.com/CourtBouillon/tinyhtml5/
+ https://pypi.org/project/tinyhtml5/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/webencodings-0.5.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest