summaryrefslogtreecommitdiff
path: root/dev-python/tikzplotlib
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tikzplotlib')
-rw-r--r--dev-python/tikzplotlib/Manifest4
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.9.11.ebuild48
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.9.12.ebuild48
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/tikzplotlib/Manifest b/dev-python/tikzplotlib/Manifest
index 395e584c9382..7e2a89169b11 100644
--- a/dev-python/tikzplotlib/Manifest
+++ b/dev-python/tikzplotlib/Manifest
@@ -1,3 +1,7 @@
+DIST tikzplotlib-0.9.11.gh.tar.gz 97761 BLAKE2B 95454a9181b219e99970d06a0e40d518284ff62c7b06d9cbf5b3125b11a711e67f9df1676dc1bd73a9ec632fa01786890e3eef030f8a52ffe809835e3890359c SHA512 05fa8285f4912f2593a00ec5961f4ca94964c2ff8271158c6c1e0447f1f2b54088a76192bcda4f893adc2ad78b9240742962eee1e56043777b0df145808f42ba
+DIST tikzplotlib-0.9.12.gh.tar.gz 97773 BLAKE2B 85d85445e313a41ede8c2d61d8db0d92a8f4fbb0722f716845f0fff3204e603e8b21998a588137eb67bdbc4d8f31bc5bfc82e29fc803b3c54c416191b6e5310b SHA512 4754707727eda29796a49809473b840c07b2cb7de606089d79aeb05daa6ded95a3f110deffb13ca2640e44d91c43b53520d6f29b175e200862492cb986b6c574
DIST tikzplotlib-0.9.9.tar.gz 591659 BLAKE2B c8ed8069387aedc154ea1541c7e4f97cd43a74c384be4810029acf2dd1de348d732c004850b3248ba6a892451afec56fc4de0c6b05c3f4edc7b72b741e46b558 SHA512 3b6bc8b23693b1817b7f8969352bfe45f81762f86d30b9329c3c57fb1897ee5965f5759e357bbe68d21b84ac3e53e5ce80ffafccfac22d9a4a36ce104d5a2966
+EBUILD tikzplotlib-0.9.11.ebuild 1082 BLAKE2B 5efb22bd6a05ef85456cbcc639b3f49850d64fec4bb5102027a07fb99ebf179e6b93ff6fe72ac1ff8951e0d09ba4f7cd327480380da1e09ef1b520917d644b1c SHA512 46f28ad8596c02820f0103aa20be699f8599d8c957e9597e6199fd11865ded29f5ccc77f9cc7bb6542259de83f12fb31102998e53f45a24009045ab6c01a3424
+EBUILD tikzplotlib-0.9.12.ebuild 1082 BLAKE2B 5efb22bd6a05ef85456cbcc639b3f49850d64fec4bb5102027a07fb99ebf179e6b93ff6fe72ac1ff8951e0d09ba4f7cd327480380da1e09ef1b520917d644b1c SHA512 46f28ad8596c02820f0103aa20be699f8599d8c957e9597e6199fd11865ded29f5ccc77f9cc7bb6542259de83f12fb31102998e53f45a24009045ab6c01a3424
EBUILD tikzplotlib-0.9.9.ebuild 922 BLAKE2B b4815d76979b0b54774c1907b447482c512e5aa56c3d92eac67b204580fcb157ed1b2d63039c6e67c578d31cd75cc300208e99c233c910214177d25830577928 SHA512 87cb7ac58c25c67c1337e0122aedd405aa29a0515cc55c9a6b833e11b0d00e21a6397a9e9f6bdbf427c4b2c2921925305b9de21bf6c35e52b3978de243fc4110
MISC metadata.xml 971 BLAKE2B 9bce78f1e6c08facc5705eaebeb99170e50d62a3e35d55aeaf746cc9a3b81f12fd67761f8582505e5916e62301f2962776f656e1242f17646efc3ccc08010dc9 SHA512 1490aea00c7e5fa17fe52f59366308740c4c247d5da77f4a64ea3118ec69517ee8f94b977d2048a7f3824b737c28dff7d5d51214c99557bac4cd11e12de5ced2
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.9.11.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.9.11.ebuild
new file mode 100644
index 000000000000..be7409c6cc0e
--- /dev/null
+++ b/dev-python/tikzplotlib/tikzplotlib-0.9.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/tikzplotlib"
+SRC_URI="
+ https://github.com/nschloe/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/texlive[extra]
+ dev-python/matplotlib[latex,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/exdown[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/mock
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ local deselect=(
+ tests/test_barchart_errorbars.py::test
+ tests/test_colorbars.py::test
+ tests/test_fillstyle.py::test
+ )
+
+ virtx epytest ${deselect[@]/#/--deselect }
+}
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.9.12.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.9.12.ebuild
new file mode 100644
index 000000000000..be7409c6cc0e
--- /dev/null
+++ b/dev-python/tikzplotlib/tikzplotlib-0.9.12.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/tikzplotlib"
+SRC_URI="
+ https://github.com/nschloe/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/texlive[extra]
+ dev-python/matplotlib[latex,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/exdown[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/mock
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ local deselect=(
+ tests/test_barchart_errorbars.py::test
+ tests/test_colorbars.py::test
+ tests/test_fillstyle.py::test
+ )
+
+ virtx epytest ${deselect[@]/#/--deselect }
+}