summaryrefslogtreecommitdiff
path: root/dev-python/thriftpy2/thriftpy2-0.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/thriftpy2/thriftpy2-0.5.0.ebuild')
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.5.0.ebuild14
1 files changed, 1 insertions, 13 deletions
diff --git a/dev-python/thriftpy2/thriftpy2-0.5.0.ebuild b/dev-python/thriftpy2/thriftpy2-0.5.0.ebuild
index 53fdb44f8d8e..3795d532cc5b 100644
--- a/dev-python/thriftpy2/thriftpy2-0.5.0.ebuild
+++ b/dev-python/thriftpy2/thriftpy2-0.5.0.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} )
-inherit distutils-r1 flag-o-matic pypi
+inherit distutils-r1 pypi
DESCRIPTION="Pure python approach of Apache Thrift"
HOMEPAGE="
@@ -33,18 +33,6 @@ BDEPEND="
distutils_enable_tests pytest
-src_compile() {
- # -Werror=strict-aliasing
- # https://bugs.gentoo.org/857105
- # https://github.com/Thriftpy/thriftpy2/issues/246
- #
- # Don't trust this to LTO
- append-flags -fno-strict-aliasing
- filter-lto
-
- distutils-r1_src_compile
-}
-
python_test() {
local EPYTEST_DESELECT=(
tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_exception