summaryrefslogtreecommitdiff
path: root/dev-python/thrift/thrift-0.13.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/thrift/thrift-0.13.0.ebuild')
-rw-r--r--dev-python/thrift/thrift-0.13.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/thrift/thrift-0.13.0.ebuild b/dev-python/thrift/thrift-0.13.0.ebuild
new file mode 100644
index 000000000000..b2f881814cc9
--- /dev/null
+++ b/dev-python/thrift/thrift-0.13.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of Thrift"
+HOMEPAGE="https://pypi.org/project/thrift/ https://thrift.apache.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}