summaryrefslogtreecommitdiff
path: root/dev-python/threadpoolctl/threadpoolctl-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/threadpoolctl/threadpoolctl-2.1.0.ebuild')
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-2.1.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/threadpoolctl/threadpoolctl-2.1.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-2.1.0.ebuild
new file mode 100644
index 000000000000..1d26d7c49723
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-2.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="https://github.com/joblib/threadpoolctl"
+SRC_URI="https://github.com/joblib/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+# tests require openmp python bindings...
+RESTRICT=test
+
+distutils_enable_tests pytest