summaryrefslogtreecommitdiff
path: root/dev-python/texttable/texttable-1.6.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/texttable/texttable-1.6.2.ebuild')
-rw-r--r--dev-python/texttable/texttable-1.6.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/texttable/texttable-1.6.2.ebuild b/dev-python/texttable/texttable-1.6.2.ebuild
new file mode 100644
index 000000000000..7b84c8a238b9
--- /dev/null
+++ b/dev-python/texttable/texttable-1.6.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for creating simple ASCII tables"
+HOMEPAGE="https://github.com/foutaise/texttable https://pypi.org/project/texttable/"
+SRC_URI="https://github.com/foutaise/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cjk test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )
+ )
+"
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]
+ cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -vv tests.py || die
+}