summaryrefslogtreecommitdiff
path: root/dev-python/textdistance
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/Manifest2
-rw-r--r--dev-python/textdistance/textdistance-4.6.3.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/textdistance/Manifest b/dev-python/textdistance/Manifest
index 339beeb8dffd..ba7579f4304b 100644
--- a/dev-python/textdistance/Manifest
+++ b/dev-python/textdistance/Manifest
@@ -1,3 +1,5 @@
DIST textdistance-4.6.2.gh.tar.gz 46619 BLAKE2B 0a205bd5615f252f4ab832597b26cd81f3a817fa9544675b947b2ba8a9d8c128ad261a09fb1ee118e0ca807ff7721f3594de5da11f5df59c90c2d9b7110b84ff SHA512 4e5ec7ef76cfd45b05f5813d624d934a6aa90c326b8bc1af50fdde51c4fda141d5aa826e7a145f4cf59f7d7cbcdcf775746eeb197a2adef3c62ad8570d699890
+DIST textdistance-4.6.3.gh.tar.gz 46631 BLAKE2B 9d4c2172934ba14326fe8ecdf7e955cd664196e58d8cc0c58f712525e6ea3aaa267879c09ba5a67ab015f6abd37593af959f02262c5a4a2fa08a859fe38a52b4 SHA512 ad9b8e031a8ae11dd2cd0f8ee8ee42f15e14eccc05910a45b4b5bf2f2048c4895da354832f88957502998b423616a54e64b94a093e4ddb7be2744c19e7f283e9
EBUILD textdistance-4.6.2.ebuild 691 BLAKE2B 4c67d2fbbe0adc1c02ae5fe505e8573be0e342fe4b6d8e6237715871ff9885dab3367454a94c1a39609adfcfa6636014634d696ea985266e318a7695a30ef0ca SHA512 8e9de580203a53041c2b82fa48cf6efe0cd4003e80c9975fd093538fc65c4d1149468f551da014a8d92f82043a90af37539017af69ab98c7117321ff8f514550
+EBUILD textdistance-4.6.3.ebuild 694 BLAKE2B 3604dff0b26ac6d1d14c442170b1229f2b8bdcf5c36d4b73bf38e8cc2278d5410677f8f1184968a19f992b020480a3081a184892a94b757b7627d45cd8e6c508 SHA512 cd8dac499dfa8a3568d3c16957914b490b35d08eef5ede59141e00b8dcdb4e14f136897c366bce0052a6e841ee5151b401304123c0a15a36e1b90817efa6251b
MISC metadata.xml 517 BLAKE2B a429684151f5700f148c5350b16026e797fdedc80b950d3c79c050a4d7418763918a05936eaeeed07b9756d9ec39602128570cd8c27049234bbda27e006ff00f SHA512 be445c2c21f5fd0bee241f8f76094b51c2fcbd7fe0d2175f7455beb881c3b83e8070c8a14817695d2b7a7dfabcdb856e12d7749aadc91ca31f7af8187e9a409e
diff --git a/dev-python/textdistance/textdistance-4.6.3.ebuild b/dev-python/textdistance/textdistance-4.6.3.ebuild
new file mode 100644
index 000000000000..cbe654456441
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.6.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="
+ https://github.com/life4/textdistance/
+ https://pypi.org/project/textdistance/
+"
+SRC_URI="
+ https://github.com/life4/textdistance/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_external.py
+)