summaryrefslogtreecommitdiff
path: root/dev-python/testtools/testtools-0.9.36.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testtools/testtools-0.9.36.ebuild')
-rw-r--r--dev-python/testtools/testtools-0.9.36.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/testtools/testtools-0.9.36.ebuild b/dev-python/testtools/testtools-0.9.36.ebuild
deleted file mode 100644
index 3c816291c9e1..000000000000
--- a/dev-python/testtools/testtools-0.9.36.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 versionator
-
-#SERIES="$(get_version_component_range 1-2)"
-SERIES="trunk"
-
-DESCRIPTION="Extensions to the Python unittest library"
-HOMEPAGE="https://launchpad.net/testtools https://pypi.org/project/testtools/"
-SRC_URI="https://launchpad.net/${PN}/${SERIES}/${PV}/+download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="dev-python/mimeparse[${PYTHON_USEDEP}]
- dev-python/extras[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( $(python_gen_cond_dep 'dev-python/twisted-core[${PYTHON_USEDEP}]' python2_7) )"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_prepare_all() {
- # Take out failing tests
- # https://bugs.launchpad.net/testtools/+bug/1380918
- sed -e 's:test_test_module:_&:' -e 's:test_test_suite:_&:' \
- -i testtools/tests/test_distutilscmd.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}