summaryrefslogtreecommitdiff
path: root/dev-python/testresources/testresources-2.0.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testresources/testresources-2.0.1-r2.ebuild')
-rw-r--r--dev-python/testresources/testresources-2.0.1-r2.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/testresources/testresources-2.0.1-r2.ebuild b/dev-python/testresources/testresources-2.0.1-r2.ebuild
deleted file mode 100644
index 68b526d7eee5..000000000000
--- a/dev-python/testresources/testresources-2.0.1-r2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A pyunit extension for managing expensive test resources"
-HOMEPAGE="
- https://launchpad.net/testresources/
- https://github.com/testing-cabal/testresources/
- https://pypi.org/project/testresources/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- test? (
- dev-python/testtools[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-python_prepare_all() {
-# sed \
-# -e 's:testBasicSortTests:_&:g' \
-# -i testresources/tests/test_optimising_test_suite.py || die
- distutils-r1_python_prepare_all
-}