summaryrefslogtreecommitdiff
path: root/dev-python/tenacity
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tenacity')
-rw-r--r--dev-python/tenacity/Manifest2
-rw-r--r--dev-python/tenacity/tenacity-8.4.1.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/tenacity/Manifest b/dev-python/tenacity/Manifest
index 2817ad71d9af..cbebfdc9d753 100644
--- a/dev-python/tenacity/Manifest
+++ b/dev-python/tenacity/Manifest
@@ -1,3 +1,5 @@
DIST tenacity-8.3.0.tar.gz 43608 BLAKE2B fcf7471110c831cfab20c81bb0bfa2c2895ce33b6cdf22c21dfd0f219eeb674dc4e7f4186e7c9a3366574636becd7391d68acb285069844ccaf358da6afa9c02 SHA512 46152ffacc0a87931cec09bd90eed3d2ad46f89101997c5da2aa510844c814b887a83805b4ec0de6a56759a7f2bcbab0cb2b2f1a4e6c11860ae53f64ff2a4c31
+DIST tenacity-8.4.1.tar.gz 45426 BLAKE2B e5cb1ed5a93a28a5733b7c25f95a5d9c4d4e341b5185c235e93bcf681590a72cd3895a1e9b24eaa31b939168f6420e8a28a5d8b982847886e9a799a983d41df8 SHA512 7abf17c5c4dbcb45aff3b660f70daa80fc673aa36e0ed95941a566d3740238d051736bc0da330110300bd4beae9a8a56082c4348d24e6bfa20a269bac771d956
EBUILD tenacity-8.3.0.ebuild 598 BLAKE2B 4b05acdf59ce38c8cfdc45e43522567204580f079b17b8a25b48fcd01e8a851560fd3b3cef939fc9262226dce7da6d58493e3339a1345fdf233e828e94ebf086 SHA512 13e643dba3b3aef847283c45a4f556e69c3b1b203501c0f42936cf0cb56b5592d1c58a4140b2361fe9f8de81b74dc83366ad9948fc8e2e7d5debc301abfe6c03
+EBUILD tenacity-8.4.1.ebuild 601 BLAKE2B 260c9f08c3309795069d4018c81bbe6517f87e7c4e64c9a1de54060b6d3c63a722a034f1ded2abc51c4acacc8ec921aff4f2dd4f96bcc1bd306575e5e92ee9e1 SHA512 2814f60a483d8c8bf484bbdbc9c0717891480958e3fd609b33cb815f5c2913161765bb7297e5d92b513defe67e80f323917666941a5a6deaa3b84cc00dd754c5
MISC metadata.xml 856 BLAKE2B af0d5417912404af6b5be19c32d150db197d27b55681871cbd45f983d1caf8b8ba7c8c44936b1465ecf00b4d185552399d0023bbfc16e84451e4fbf006eefcab SHA512 1fe2c8617bfaeba198a8b5430c2b38acf60f17c29fc89599d198037310589b4a5bb1170919e2f57c3e27951288d06ab281ec5a55ae64e6a0a33296a89be17839
diff --git a/dev-python/tenacity/tenacity-8.4.1.ebuild b/dev-python/tenacity/tenacity-8.4.1.ebuild
new file mode 100644
index 000000000000..6b916a7dff79
--- /dev/null
+++ b/dev-python/tenacity/tenacity-8.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="
+ https://github.com/jd/tenacity/
+ https://pypi.org/project/tenacity/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/tornado-6.4-r1[${PYTHON_USEDEP}]
+ dev-python/typeguard[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest