summaryrefslogtreecommitdiff
path: root/dev-python/tenacity/tenacity-8.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tenacity/tenacity-8.0.0.ebuild')
-rw-r--r--dev-python/tenacity/tenacity-8.0.0.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/tenacity/tenacity-8.0.0.ebuild b/dev-python/tenacity/tenacity-8.0.0.ebuild
deleted file mode 100644
index 4d837bd1e2de..000000000000
--- a/dev-python/tenacity/tenacity-8.0.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="General-purpose retrying library"
-HOMEPAGE="https://github.com/jd/tenacity"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- www-servers/tornado[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # TODO: package typeguard
- tests/test_tenacity.py::TestRetryTyping::test_retry_type_annotations
- )
-
- epytest ${deselect[@]/#/--deselect }
-}