summaryrefslogtreecommitdiff
path: root/dev-python/sure
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sure')
-rw-r--r--dev-python/sure/Manifest2
-rw-r--r--dev-python/sure/sure-2.0.0-r1.ebuild (renamed from dev-python/sure/sure-2.0.0.ebuild)25
2 files changed, 16 insertions, 11 deletions
diff --git a/dev-python/sure/Manifest b/dev-python/sure/Manifest
index dd396752d725..3613f233de4f 100644
--- a/dev-python/sure/Manifest
+++ b/dev-python/sure/Manifest
@@ -1,3 +1,3 @@
DIST sure-2.0.0.tar.gz 46747 BLAKE2B 631923bf2fc0a972e276fbfd1918abbafec28e662669993b40ff8ca72944952d092ac662728f98a286fc9b5c8e3765d10a4d6ef1f17b17655802b971b97410af SHA512 8286846374c2bfc773444e90bf4f9c0b0d66d0229afa53af63025bfec690bf8bcc959f86c238ca5244c6a29099e955691771b0eb954af479bde2f17e51f6f1de
-EBUILD sure-2.0.0.ebuild 837 BLAKE2B 2a7e4fc22802a46281ac702ea3f2a11ca8593f37149d23428a34ae384a855dc69e4a6513cdbb9a58ebd2089d39d458d4344b016c0203d8d59b6fbd6f0054c6b7 SHA512 207318358e92724eca2cf9905b27ac531b511db0a07d5117961a31be12945755161f25e644eedb8fc4c31c06d60f5790ea420d34367100e8b5ee96345419be65
+EBUILD sure-2.0.0-r1.ebuild 773 BLAKE2B 06ca39dafc75f7c94b42d52257538c3d60b6892a74486bddfe6b2f158092054c5976d9d310844c66d2451d869ad1d362ee2a2f03c4032d4ac9221da59f95a2ca SHA512 6cd4de4b91c697aa7c4206ea55a97e388087766a65c6d1739c0dac350689f0a30e0e6c4d3226986ee521703299de57889499e64c991ca686a9f27accbc31b0e6
MISC metadata.xml 583 BLAKE2B 3a551f125c9df8f77a05b69cf54b30d94bace7869decb608b3685e06a7cb9f1462d4e674d06d59d84100e06ee95cce30a68c4777632bb0691397f1e6faaa26ef SHA512 57b87cbde1f34395fbd42bc8f7712aaf193aded2248815cb6919cb51387227f1cab46dd0d1595be9a55bdd131ac554e401366c3740c3d01782b8329a6f8e6588
diff --git a/dev-python/sure/sure-2.0.0.ebuild b/dev-python/sure/sure-2.0.0-r1.ebuild
index 974c93d4926c..6fdca046fed5 100644
--- a/dev-python/sure/sure-2.0.0.ebuild
+++ b/dev-python/sure/sure-2.0.0-r1.ebuild
@@ -1,14 +1,18 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="idiomatic assertion toolkit with human-friendly failure messages"
-HOMEPAGE="https://github.com/gabrielfalcao/sure"
+HOMEPAGE="
+ https://github.com/gabrielfalcao/sure/
+ https://pypi.org/project/sure/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-3+"
@@ -17,16 +21,17 @@ KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86"
RDEPEND="
dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-distutils_enable_tests nose
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires dev-python/nose
+ tests/test_old_api.py
+)
src_prepare() {
- # remove unnecessary dep
- sed -i -e '/rednose/d' setup.cfg || die
- # broken test with python 3.10, but when manually run, passes
- sed -e 's/test_context_is_not_optional/_&/' -i tests/test_old_api.py || die
+ sed -i -e 's:--cov=sure::' setup.cfg || die
distutils-r1_src_prepare
}