summaryrefslogtreecommitdiff
path: root/dev-python/sunpy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sunpy')
-rw-r--r--dev-python/sunpy/Manifest5
-rw-r--r--dev-python/sunpy/metadata.xml18
-rw-r--r--dev-python/sunpy/sunpy-0.7.9.ebuild51
-rw-r--r--dev-python/sunpy/sunpy-0.8.0.ebuild51
4 files changed, 125 insertions, 0 deletions
diff --git a/dev-python/sunpy/Manifest b/dev-python/sunpy/Manifest
new file mode 100644
index 000000000000..bb8b0bb36068
--- /dev/null
+++ b/dev-python/sunpy/Manifest
@@ -0,0 +1,5 @@
+DIST sunpy-0.7.9.tar.gz 5690849 SHA256 359961f62a32df69b2df2cd5390040fa27b7522066fb546469fc9f485d2d0a57 SHA512 e8322ecf7c797a377fd8ff6962d6d66e147ba893a58e8abbbfa1dad6a391eecc161846a51fba3c92e90a3709125d759da76d444ca3f4ff0878768d23da1f41a3 WHIRLPOOL 512e1f5fbc0c4e127c4fc26fcd3f7f2c7ce0944ca5691fcdb938254615e131d14407f4bb160a32b597ad62a520c59201afee2ae6a133021a7c0d7d4cf9298ab9
+DIST sunpy-0.8.0.tar.gz 6336169 SHA256 54c894719a38e66a9e5fb89ce0555fe714f37e54179a25f4f16b6c9da3c10f1a SHA512 7996fdcb47e4143159253180b2250ea7ac4aa8fecf8d3f1eae930da018d39ce4e663c843b4b0532e900f97d2bc9fadfd7c17837f4f045634820059a5af802eda WHIRLPOOL 08b3ef4c3c6503ce10f9d9e7d04b4310604376b09ae18066296f86b95c5292f5e8b1e789d10d9e697b82a55d85d94ab2f7b3eeebe855926a434d6518ec31ec0b
+EBUILD sunpy-0.7.9.ebuild 1384 SHA256 01f078b201e91b2d4d8b888c56cada3fe8a79465304e4ad8031d26d4d87205da SHA512 86fe8035ffd52450d4d0b4ccccffa4b41fdceeb7d62eee7a2e9bc79626a7b0260018ca92f93dd5cd18b78d6515825864bcd55c43c45e258caf68ce86d3b02209 WHIRLPOOL 41578b23dbac2d233d21fec3cfc73e0c170ead8f76ddfef3e9062a9e5908c0fefdefd06aaa02d2b8731c4c366eb0b5e712d04d4fe4d018b422fef57da80fe4d4
+EBUILD sunpy-0.8.0.ebuild 1418 SHA256 8034d96bf165d354b81d85720d600af542d573d5c8168967029c5430f53cbeeb SHA512 55b878b6b781450079f921c183346d955767e15a27c8dfee7f736a9d3c0971c1e01e2b2609094e4d054f8026c876304b53fea7ad0314fb8a99fc7ed433c1fcc2 WHIRLPOOL 255f9b730d17cd72c10e9e950850aba53303508262f72bb128b37091b7569a4fa7226269f477526011d833e98826df2bb8201f65fb70acdf63cc8ef5a23dae09
+MISC metadata.xml 746 SHA256 2090e70a553fb5f7e4ea0e0308411ec4496f51eb36e067191c621caf4271214c SHA512 73242a446a71a5f670e1993dd20ed2a66f06a3f3751e351edd9f24a2e77989f0aafde489b348d51264c0e4b1eca5fe34552b7378dc0bd19a8c351294adeb2b26 WHIRLPOOL 033541578ef1bcb1782e9e1fbe5ec8c5a450cb9b0b60417f151543f492a167613e113fa5cfd23177664ccb6cb3ae612c59601779469365e41fe6732cb3138d00
diff --git a/dev-python/sunpy/metadata.xml b/dev-python/sunpy/metadata.xml
new file mode 100644
index 000000000000..1915944eec82
--- /dev/null
+++ b/dev-python/sunpy/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ SunPy is a community-developed free and open-source software package for
+ solar physics. SunPy is meant to be a free alternative to the SolarSoft data
+ analysis environment. The aim of the SunPy project is to provide the
+ software tools necessary so that anyone can analyze solar data.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">sunpy</remote-id>
+ <remote-id type="github">sunpy/sunpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sunpy/sunpy-0.7.9.ebuild b/dev-python/sunpy/sunpy-0.7.9.ebuild
new file mode 100644
index 000000000000..9d1336d23d42
--- /dev/null
+++ b/dev-python/sunpy/sunpy-0.7.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Software library for solar physics based on Python"
+HOMEPAGE="http://sunpy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="jpeg2k test"
+
+RDEPEND="
+ <dev-python/astropy-2[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/suds[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/scikits_image[${PYTHON_USEDEP}]
+ jpeg2k? ( dev-python/glymur[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mpl[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m pytest sunpy -k "not figure and not online" || die
+}
diff --git a/dev-python/sunpy/sunpy-0.8.0.ebuild b/dev-python/sunpy/sunpy-0.8.0.ebuild
new file mode 100644
index 000000000000..4aa502509e14
--- /dev/null
+++ b/dev-python/sunpy/sunpy-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Software library for solar physics based on Python"
+HOMEPAGE="http://sunpy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="jpeg2k test"
+
+RDEPEND="
+ >=dev-python/astropy-2[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/suds[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/scikits_image[${PYTHON_USEDEP}]
+ jpeg2k? ( dev-python/glymur[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-mpl[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m pytest sunpy -k "not figure and not online" || die
+}