summaryrefslogtreecommitdiff
path: root/dev-python/stomp-py
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/stomp-py')
-rw-r--r--dev-python/stomp-py/Manifest4
-rw-r--r--dev-python/stomp-py/metadata.xml2
-rw-r--r--dev-python/stomp-py/stomp-py-8.1.2.ebuild30
3 files changed, 34 insertions, 2 deletions
diff --git a/dev-python/stomp-py/Manifest b/dev-python/stomp-py/Manifest
index cbfa4f2141eb..82c9dd185a8a 100644
--- a/dev-python/stomp-py/Manifest
+++ b/dev-python/stomp-py/Manifest
@@ -1,3 +1,5 @@
DIST stomp.py-8.1.0.tar.gz 39808 BLAKE2B c6efb19fbee81142f251c4bf4114b445878b81fa457260a306cb82ef5e9c57f0b75e3dc8cd6035676e688f1d33081cdf936ac6ccc0628819722849d60f4d8602 SHA512 7385842a23fbe6022c386489641948932e805430ce71c09079d9484fe17d02241ee705d92a1bcdf873eebcbacf68f44bbf884ea103c8963944b84758073fdac7
+DIST stomp_py-8.1.2.tar.gz 39163 BLAKE2B 49d096369b427033cf1210638875cdd1501711a05183d7d186f8f926033e898c7323a8d96f319311999edc86a49515a92ba4c0ed0982712789f7ba78f4175e5e SHA512 2cbfaacdc5762b8db5c28721e01511c32a8991a866d6ced520a27cb82deacc4716cbaf5f298a8daea7f91c9038859d4c39069ad5b46ba6d0efe60e4c19ab09ae
EBUILD stomp-py-8.1.0.ebuild 978 BLAKE2B fc0f5db9d10272c3c2aa2243a15bcaadaa4f6131aeae578f2eb0a8dcc3c8609798021fa0b6e451fd97954a5861adc28248a6b374911aa53bc650adc8b0160279 SHA512 417f6e3a0fde40a5ef49c583041f5e53d217ce3e6a2f33cacf6d0c1049804859b5bbe27f4a7d6353834729aae2adfd82333ae295e8d0a5b57d4e867079322fe1
-MISC metadata.xml 402 BLAKE2B 2cca58b54cd707a4c0db87e034f4e6387e9243aabe392cd0046d11b6d2074c57285798db5a81d7f3f6854a9a43436a193678d384ccde45af0552bc50b26e77ba SHA512 770aac685fa99c5e3a01bab4864d6af4c9c810ad52c4f8a2a0c32a4303f0e5e9a1573d7ad6220737e6fa4093c5a1430fb2a7765a151bcd5aa9925e059d5bed41
+EBUILD stomp-py-8.1.2.ebuild 991 BLAKE2B 6152cac78d0559d62cafef3237e6d709f0c5ad331f7bf4919e6c6ea818d15d6f6c03f818ac1462f823810473d509c4c36f614fd3b7d33e173a60c9f0e8509a2a SHA512 e2139cbdbb7f90def2c1e6c7ae59e595db353ea44c23543eb9c7ba0ae2bdf0236b0e49037cac7d0becc1a411603667a0c2a38715017ec7e7665f5c137bf67efc
+MISC metadata.xml 402 BLAKE2B f4a4997af910bccc3ffb2e847ae3262f087d6546ba5b50a078498d651388b652b2f1647661e7870b2517d257330ceb234b31295ef7b7130abd4b8693abb3f580 SHA512 d47bd175f6a78efafac027a1ae84bf84fad84893aa285ba7d21acae6cb01406a52e31a83999f13584abd7219cdcb73eec3b435c3093d1b340c31d600b469747f
diff --git a/dev-python/stomp-py/metadata.xml b/dev-python/stomp-py/metadata.xml
index 256ce6712373..d1b716fd203c 100644
--- a/dev-python/stomp-py/metadata.xml
+++ b/dev-python/stomp-py/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="pypi">stomp.py</remote-id>
+ <remote-id type="pypi">stomp-py</remote-id>
<remote-id type="github">jasonrbriggs/stomp.py</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/stomp-py/stomp-py-8.1.2.ebuild b/dev-python/stomp-py/stomp-py-8.1.2.ebuild
new file mode 100644
index 000000000000..3a88a66c6b28
--- /dev/null
+++ b/dev-python/stomp-py/stomp-py-8.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python client library for the STOMP messaging protocol"
+HOMEPAGE="https://pypi.org/project/stomp-py/ https://github.com/jasonrbriggs/stomp.py/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/docopt-0.7.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+
+# stomp.py test suite requires quite a few appropriately configured
+# messaging servers (as of 8.1.2: RabbitMQ, ActiveMQ, ActiveMQ Artemis,
+# stompserver). Upstream relies on Docker to provide those servers, however
+# doing the same in src_test would require both granting the portage user
+# extra permissions and packaging the base image (trying to download it
+# on the fly would violate the network sandbox).
+# Side note: PyPI tarballs do not include tests.
+RESTRICT="test"