summaryrefslogtreecommitdiff
path: root/dev-python/stestr/stestr-2.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/stestr/stestr-2.1.0-r1.ebuild')
-rw-r--r--dev-python/stestr/stestr-2.1.0-r1.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/stestr/stestr-2.1.0-r1.ebuild b/dev-python/stestr/stestr-2.1.0-r1.ebuild
index 7c18fc139cbe..7163c33b49cf 100644
--- a/dev-python/stestr/stestr-2.1.0-r1.ebuild
+++ b/dev-python/stestr/stestr-2.1.0-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
+EAPI=7
PYTHON_COMPAT=( python3_6 python3_6 python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
inherit distutils-r1
DESCRIPTION="A parallel Python test runner built around subunit"
@@ -12,16 +13,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
KEYWORDS="~alpha amd64 arm64 hppa ~ia64 ~mips ~ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE=""
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
-RDEPEND="
- ${CDEPEND}
+DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
dev-python/future[${PYTHON_USEDEP}]
>=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
>=dev-python/subunit-0.18.0[${PYTHON_USEDEP}]