summaryrefslogtreecommitdiff
path: root/dev-python/statsd/statsd-4.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/statsd/statsd-4.0.1.ebuild')
-rw-r--r--dev-python/statsd/statsd-4.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/statsd/statsd-4.0.1.ebuild b/dev-python/statsd/statsd-4.0.1.ebuild
new file mode 100644
index 000000000000..b92830f6e6a2
--- /dev/null
+++ b/dev-python/statsd/statsd-4.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple statsd client"
+HOMEPAGE="
+ https://github.com/jsocol/pystatsd/
+ https://pypi.org/project/statsd/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest statsd/tests.py
+}