summaryrefslogtreecommitdiff
path: root/dev-python/statsd/statsd-4.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-07 09:21:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-07 09:21:27 +0000
commit85ba3f2cfe9ff2b952efb1f3c3c08840f8093246 (patch)
treec8adb7f2695744136c00d176bd0ebd80677049aa /dev-python/statsd/statsd-4.0.1.ebuild
parentf9c971dedd369d9f45a38f3fae51467e864f5324 (diff)
gentoo auto-resync : 07:11:2022 - 09:21:27
Diffstat (limited to 'dev-python/statsd/statsd-4.0.1.ebuild')
-rw-r--r--dev-python/statsd/statsd-4.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/statsd/statsd-4.0.1.ebuild b/dev-python/statsd/statsd-4.0.1.ebuild
new file mode 100644
index 000000000000..b92830f6e6a2
--- /dev/null
+++ b/dev-python/statsd/statsd-4.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple statsd client"
+HOMEPAGE="
+ https://github.com/jsocol/pystatsd/
+ https://pypi.org/project/statsd/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest statsd/tests.py
+}