summaryrefslogtreecommitdiff
path: root/dev-python/sqlglot
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest3
-rw-r--r--dev-python/sqlglot/sqlglot-26.13.0.ebuild96
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index ddc8706f36bb..3e31bd103d5f 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -1,4 +1,7 @@
DIST sqlglot-26.12.1-crates.tar.xz 8327388 BLAKE2B 69213d11940f9d4e743b169ef831b8b52a771f012e247570cf0703580a14af435d4d033b4b3ddfca6f4022b741261a24f3b47e5137de644d863714006520f857 SHA512 5de0781c54265b369e5e46b7cfbcc04a3118aa8d1323bff14f2841c95d471f545c923eedb88dbbb81a910801c5a505ff37a25701af936c06cf55a1659cd8822e
DIST sqlglot-26.12.1.tar.gz 5341371 BLAKE2B 73d45669337786903f5e3e14683e96fa4d258696cd1116d3f82034437178612651e8c804cfb072cae444bd6a0d0496556f20e459d3d7470700215e16c23cb4af SHA512 2839c23d6ffd3dc2fc63258b43485c6f8471cdadec3be53012fccad41158ca834ac6aef41b21c004a749be130fef40d5747cb0d88a9a22c8dedf3b153c675aa2
+DIST sqlglot-26.13.0-crates.tar.xz 8327388 BLAKE2B 69213d11940f9d4e743b169ef831b8b52a771f012e247570cf0703580a14af435d4d033b4b3ddfca6f4022b741261a24f3b47e5137de644d863714006520f857 SHA512 5de0781c54265b369e5e46b7cfbcc04a3118aa8d1323bff14f2841c95d471f545c923eedb88dbbb81a910801c5a505ff37a25701af936c06cf55a1659cd8822e
+DIST sqlglot-26.13.0.tar.gz 5346071 BLAKE2B c2bb4db94e58a60f958171ed30af2d5f87f61bc79c7638ef0fb569c221431f5da34c0dcf87391a49a4c8185c0070fb163c08b66965b5dcf3c0ce3a8680818dd9 SHA512 2ee7cb506bc67b17e325fd79114987a94d7c6742571d183cf4669b4db671e7413a2303473e52f1a9600bac30b5290bb93942bc13d7ddfc069d4ad17f99865152
EBUILD sqlglot-26.12.1.ebuild 2181 BLAKE2B b318f9b2641e9d5df2f6c3be9b7bf4e3f1dd026ea00d3242c8b6a813549c3706188066580f007776670701dd8cb4fb2eb6fa6385a902b0b1eba94820f9d89879 SHA512 86a7394602d8f507c4c999e1b8530b01824fd039d1cf5f9d53b9685f3b48d8e9893155c5d2ecd8cd0350f0d98f17ccdb9623738ab1e4f58968607d7e7067c700
+EBUILD sqlglot-26.13.0.ebuild 2181 BLAKE2B b318f9b2641e9d5df2f6c3be9b7bf4e3f1dd026ea00d3242c8b6a813549c3706188066580f007776670701dd8cb4fb2eb6fa6385a902b0b1eba94820f9d89879 SHA512 86a7394602d8f507c4c999e1b8530b01824fd039d1cf5f9d53b9685f3b48d8e9893155c5d2ecd8cd0350f0d98f17ccdb9623738ab1e4f58968607d7e7067c700
MISC metadata.xml 611 BLAKE2B 10bf684677182565c9932d51ed9b3b9c80d376d6db945bd7b0dd0d9a19a85dc0d10cb169ff2048ae5f7f73d0f438d259b6231c13c525b5374ec99377f4ffdd10 SHA512 2b26d0f77962807052b94ad78addcfdce9859042af3be34df267dc6e70b6231dd779563935fd21955cd8646fd0cce3fee8c939387ac8056194a0b777743dd2ae
diff --git a/dev-python/sqlglot/sqlglot-26.13.0.ebuild b/dev-python/sqlglot/sqlglot-26.13.0.ebuild
new file mode 100644
index 000000000000..dfb5ad04a049
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-26.13.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES=""
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+CARGO_OPTIONAL=1
+
+inherit cargo distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+SRC_URI+="
+ native-extensions? (
+ https://github.com/gentoo-crate-dist/sqlglot/releases/download/v${PV}/${P}-crates.tar.xz
+ )
+"
+
+LICENSE="MIT"
+LICENSE+=" native-extensions? ("
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 Apache-2.0-with-LLVM-exceptions MIT Unicode-DFS-2016
+"
+LICENSE+=" )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+native-extensions"
+
+BDEPEND="
+ native-extensions? (
+ ${RUST_DEPEND}
+ dev-util/maturin[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/sqlglotrs/sqlglotrs.*.so"
+
+pkg_setup() {
+ use native-extensions && rust_pkg_setup
+}
+
+src_unpack() {
+ cargo_src_unpack
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ if use native-extensions; then
+ local DISTUTILS_USE_PEP517=maturin
+ local DISTUTILS_UPSTREAM_PEP517=maturin
+ cd sqlglotrs || die
+ distutils-r1_python_compile
+ cd - >/dev/null || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # timing, sigh
+ # https://github.com/tobymao/sqlglot/issues/3961
+ tests/test_generator.py::TestGenerator::test_generate_nested_binary
+ )
+ local EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+ )
+
+ # make sure not to use an earlier installed version
+ local -x SQLGLOTRS_TOKENIZER=$(usex native-extensions 1 0)
+ rm -rf sqlglotrs || die
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}