summaryrefslogtreecommitdiff
path: root/dev-python/spyder-unittest/spyder-unittest-0.4.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/spyder-unittest/spyder-unittest-0.4.1-r1.ebuild')
-rw-r--r--dev-python/spyder-unittest/spyder-unittest-0.4.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/spyder-unittest/spyder-unittest-0.4.1-r1.ebuild b/dev-python/spyder-unittest/spyder-unittest-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..38bdd2eb9179
--- /dev/null
+++ b/dev-python/spyder-unittest/spyder-unittest-0.4.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin for Spyder to run tests and view the results"
+HOMEPAGE="https://github.com/spyder-ide/spyder-unittest"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/spyder-5.1[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+# Tests fail with spyder-5, however the plugin does load and is usable
+RESTRICT="test"
+
+distutils_enable_tests pytest
+
+python_test() {
+ spyder_unittest_test() {
+ # fails to test in ${BUILDIR}/lib
+ # test do work if executed directly in the extracted tarball
+ local PYTHONPATH="${WORKDIR}/${P}"
+ pytest -vv spyder_unittest/tests spyder_unittest/widgets/tests
+ }
+
+ virtx spyder_unittest_test
+}