summaryrefslogtreecommitdiff
path: root/dev-python/spotipy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/spotipy')
-rw-r--r--dev-python/spotipy/Manifest2
-rw-r--r--dev-python/spotipy/spotipy-2.25.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
index e99fef6c9dd0..dedabc122d13 100644
--- a/dev-python/spotipy/Manifest
+++ b/dev-python/spotipy/Manifest
@@ -1,3 +1,5 @@
DIST spotipy-2.24.0.gh.tar.gz 114822 BLAKE2B 0db73d723c1cb3818d68cfa90fd8077c6d6eb82b16f24e087907091d74644b86431aa93ea5ed9a842ec674c16f67cddc5be17a3b6cfcb92d0c01aa8bd3d1529f SHA512 9860119f078ff894a9b27bb4d51cd7b469c2cea4981757338d8c3f1c6c8a1c0bbb3b79622820486c07f0b86ce4e26f9329635b51fc976c4cee43122b9a0209ff
+DIST spotipy-2.25.0.gh.tar.gz 117172 BLAKE2B 1d8c8a286e8849b0799c66f94a2137f16b0e636e9b7ff37e19047cc7d41cc8c7183a0f6b0c73834c0746b562f4d8192a3c5d1343cd70c7d5796c5c75ca0ad0e2 SHA512 2406eb445976f6cf54ce78a92739c18453415bbf330c40f255c2ab8a4734874051d38c329b044659723da7843bc06600ffa656c9d679a984390bf16a75e2fa72
EBUILD spotipy-2.24.0.ebuild 1019 BLAKE2B e5edfd9dfca17ac93ca800f31302161a2f1614ea8dc963c5e60e848813a8f7e17a6dd3224b8a79fa2051509f0e926cf36b4ef696149d3a26c3b59e71501c0b1c SHA512 1a87c2abf18314092d5143fb269f821c5e362cd4b010632edfa1e5bfb42f2e843c980b76b4fdfdd8fd91771a142e5a95ea56b218a8d6dee82e6bdd426304897c
+EBUILD spotipy-2.25.0.ebuild 1020 BLAKE2B d0a6274280d2a47026b8c823b6903210f62958c8244261c98bac3fb3c1f2650f525f49d61d002ab103c5fb3518eb77bac31c2b86c2d8f49c587ea66a55199006 SHA512 85e6b9758b539e93634e6591e2c9a01e33f40ec9d2cad23340555446b94c078369599533a865f515f1e0acb8520cdeb0e7ae4a535b67694826f4d98f9cef10d2
MISC metadata.xml 563 BLAKE2B 59aaf72f0ef6dcd61187b4d6c4f058725954a01e692fcc3caec5d559a340cf8587950fe96af3c8e10eab4c27ed7a8074cc98ad955b576a261eb8eb9dbe4d6403 SHA512 99afcacd9adfe51850503848dcaebc3d7be85cf50a05dba05ea64c7a9af7d641dbe3db903e611030698f4c7025d99b2057a03e34eca85bc4ac4d811fe961f799
diff --git a/dev-python/spotipy/spotipy-2.25.0.ebuild b/dev-python/spotipy/spotipy-2.25.0.ebuild
new file mode 100644
index 000000000000..ab10c388d374
--- /dev/null
+++ b/dev-python/spotipy/spotipy-2.25.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight Python library for the Spotify Web API"
+HOMEPAGE="
+ https://spotipy.readthedocs.io/
+ https://github.com/spotipy-dev/spotipy/
+ https://pypi.org/project/spotipy/
+"
+SRC_URI="
+ https://github.com/spotipy-dev/spotipy/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/redis[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/redis \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/unit/test_oauth.py::TestSpotifyClientCredentials::test_spotify_client_credentials_get_access_token
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples
+}