summaryrefslogtreecommitdiff
path: root/dev-python/sphinxygen/sphinxygen-1.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxygen/sphinxygen-1.0.4.ebuild')
-rw-r--r--dev-python/sphinxygen/sphinxygen-1.0.4.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/sphinxygen/sphinxygen-1.0.4.ebuild b/dev-python/sphinxygen/sphinxygen-1.0.4.ebuild
new file mode 100644
index 000000000000..a9861725c82c
--- /dev/null
+++ b/dev-python/sphinxygen/sphinxygen-1.0.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module/script that generates Sphinx markup to describe a C API"
+HOMEPAGE="
+ https://gitlab.com/drobilla/sphinxygen
+ https://pypi.org/project/sphinxygen/
+"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests pytest