summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-pretty-searchresults
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-pretty-searchresults')
-rw-r--r--dev-python/sphinxcontrib-pretty-searchresults/Manifest3
-rw-r--r--dev-python/sphinxcontrib-pretty-searchresults/metadata.xml25
-rw-r--r--dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild42
3 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/sphinxcontrib-pretty-searchresults/Manifest b/dev-python/sphinxcontrib-pretty-searchresults/Manifest
deleted file mode 100644
index 4de45a38d242..000000000000
--- a/dev-python/sphinxcontrib-pretty-searchresults/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST sphinxcontrib-pretty-searchresults-0.3.5.tar.gz 9996 BLAKE2B 64324f306aec1d6eac9c791acc0f3f4a0a434f734abcf9bb0d34151137e20407d59e95ea3a3a981e425ded6b6fd82bd36627323a3ed493a47b92979ac5fe2f77 SHA512 30c9a0af183ffada3300c03495afb9f52fbba5522dd386c5a05a28fa1e6dd0fb66725499db7a537534496843e6707c7dcceea45511ee3953d02c3e2275e68630
-EBUILD sphinxcontrib-pretty-searchresults-0.3.5.ebuild 986 BLAKE2B a70684ea22f50d86f8e87d5f36c9f0d11ddd90dcde12d24e4bee314a98e0fbd7c55287f6e23d2121b0ee7a416bcf2fd060bcaf81168d953f8f406458246e8d22 SHA512 84388516bab12ec6b7b188e4d3dcad2072ee1aaf1c7d3c23f0234322fea409d5d9ceda278d7424515d4e6622bf06ea0d0a6f6148d8c2751e0d550d8c9ef427e7
-MISC metadata.xml 936 BLAKE2B 34793935ef5b64e806d2cf26f638a87520098d220ce0b1546f44694be606bb426a1f2d6e558ee116f6647f09e87288a1cf2342dfe1631872536289f4f2dbd354 SHA512 92fdac98a9755a66cf8b5e13567861202b6940903fbc0a83f563888bd87b753d16f7b540abcc67fbeeed087905de992b92998e884102a016041f0d7fc30465c2
diff --git a/dev-python/sphinxcontrib-pretty-searchresults/metadata.xml b/dev-python/sphinxcontrib-pretty-searchresults/metadata.xml
deleted file mode 100644
index 479261280af7..000000000000
--- a/dev-python/sphinxcontrib-pretty-searchresults/metadata.xml
+++ /dev/null
@@ -1,25 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>bernardo@standard.ai</email>
- <name>Bernardo Meurer</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Gentoo Proxy Maintainers Project</name>
- </maintainer>
- <longdescription lang="en">
- Sphinx: pretty search results is an extension for the Sphinx
- documentation tool.
-
- To display search results, Sphinx is fetching the
- source files of search hits and rendering excerpts in raw markup
- (Example). This extension removes the markup from these source files
- (during build time), so the search results look decent.
- </longdescription>
- <upstream>
- <remote-id type="pypi">sphinxprettysearchresults</remote-id>
- <remote-id type="github">sphinx-contrib/sphinx-pretty-searchresults</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild b/dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild
deleted file mode 100644
index 93849564786c..000000000000
--- a/dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{5,6,7} )
-
-inherit distutils-r1
-
-MY_PN="${PN/sphinxcontrib/sphinx}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Decently styled search results for sphinx-doc projects"
-HOMEPAGE="https://github.com/sphinx-contrib/sphinx-pretty-searchresults"
-SRC_URI="https://github.com/sphinx-contrib/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/sphinx-testing[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/recommonmark[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
-"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- cd tests || die
- "${EPYTHON}" run.py || die
-}