summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-plantuml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-plantuml')
-rw-r--r--dev-python/sphinxcontrib-plantuml/Manifest2
-rw-r--r--dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.28.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-plantuml/Manifest b/dev-python/sphinxcontrib-plantuml/Manifest
index 60b571947b2a..acb3f7249a20 100644
--- a/dev-python/sphinxcontrib-plantuml/Manifest
+++ b/dev-python/sphinxcontrib-plantuml/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-plantuml-0.27.gh.tar.gz 19268 BLAKE2B d74d85da40a9c17eb6d73bfd2890af4f4260b11001bba4f3001d84f2f9b53597c2148c14af5a853ab3c0d3a760435a3475c6bc69748c9522f66b5f1c5e01d7b2 SHA512 acf648bc83647317d717c7f69026f20cc87066e26c409daaf14ec35e874f53ba324d1b2325b82987bc54f8224293113997bbfeca78b9f14c1704ff108e083faf
+DIST sphinxcontrib-plantuml-0.28.gh.tar.gz 19322 BLAKE2B b76166130ddcebc9312ea40d20dd0710403566a989dfdc40b906a724b32d8e3b53d50a4db1871e771eafb46f9cfea463f58348910c4bdeed0f25996269be8dea SHA512 52553e8ee5a9dbb3644f28a26f6be48a910e2013673169a8a9f0776406f6453b2443967af1837056010b0621d681e7fd00ab590858b07665bb74699c81aa81e2
EBUILD sphinxcontrib-plantuml-0.27.ebuild 1018 BLAKE2B 49f51474dd5f052f3bda975fb75d1eab2b2202c6beb61e918f58272b3a034eda800231edef001fd51218f0f15ecae4116073836a7c3cd946218c0bc13bbf6476 SHA512 cd30d43b34af01da12e8fcfdb508bcbde4bbaba5332d678c7ffdf8c18a005503df779b18dc1f7402eb0f2ced595f498fd596fc87f83391915a692938aeff2222
+EBUILD sphinxcontrib-plantuml-0.28.ebuild 1020 BLAKE2B 36d475bb8f7b0b423706bb6e46673e826f180c46f6dd9481adc0940615d1745b134aaf12c5c2dc156e4f3f1af88c6d2eb1c2be6a008076ec357cc561d66e2bb0 SHA512 41875b792465be425b970fe2600a2ee95b3d7a1640d2a368b97ded342b0d824b44b7f69fa1aa0233b1a69820a01cc05bf69a51a0075602164608eadcb43a4977
MISC metadata.xml 419 BLAKE2B 05ba888453b1a19e83a8d21a5b0cc2a5a24482434b44c0f3bd4c75c99004523f6397a7a32811a336c15449ea86f1736e5a940d240d19f3956a176fce3881378d SHA512 6d8c4c646e7d84771a7ac7889650c06a0efcaa708d5e009df323f4d8ee591c75d864811ba10dde72b84f40359092302225a93d8de374da8d52033163356d6f46
diff --git a/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.28.ebuild b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.28.ebuild
new file mode 100644
index 000000000000..74c22f4418d0
--- /dev/null
+++ b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.28.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for PlantUML"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/plantuml/
+ https://pypi.org/project/sphinxcontrib-plantuml/
+"
+SRC_URI="
+ https://github.com/sphinx-contrib/plantuml/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+S="${WORKDIR}/${P#sphinxcontrib-}"
+
+BDEPEND="
+ test? (
+ app-text/texlive
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-tex/latexmk
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latexextra
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Fix for sphinx.errors.ExtensionError: Could not import extension sphinxcontrib.applehelp
+ # See https://projects.gentoo.org/python/guide/test.html#importerrors-for-c-extensions, thanks to mgorny.
+ rm -rf sphinxcontrib || die
+
+ epytest
+}