summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.4.1.ebuild')
-rw-r--r--dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.4.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.4.1.ebuild b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.4.1.ebuild
new file mode 100644
index 000000000000..11d9bca95067
--- /dev/null
+++ b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for BibTeX style citations"
+HOMEPAGE="https://github.com/mcmtroffaes/sphinxcontrib-bibtex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pybtex[${PYTHON_USEDEP}]
+ dev-python/pybtex-docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest
+distutils_enable_sphinx doc
+
+python_prepare_all() {
+ # pybtex.plugin.PluginNotFound: plugin pybtex.style.names.last not found
+ # This particular style seems to be removed?
+ rm test/test_citation.py test/test_footcite.py test/test_style.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}