summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-asyncio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-asyncio')
-rw-r--r--dev-python/sphinxcontrib-asyncio/Manifest2
-rw-r--r--dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r3.ebuild (renamed from dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild)23
2 files changed, 11 insertions, 14 deletions
diff --git a/dev-python/sphinxcontrib-asyncio/Manifest b/dev-python/sphinxcontrib-asyncio/Manifest
index f07ee5d3547d..0450654ab3f2 100644
--- a/dev-python/sphinxcontrib-asyncio/Manifest
+++ b/dev-python/sphinxcontrib-asyncio/Manifest
@@ -1,3 +1,3 @@
DIST sphinxcontrib-asyncio-0.2.0.tar.gz 10689 BLAKE2B 9e03989a1ed22d7d467bdb7626e2e908407a0de15a943a432ff9707340f0cefe7caf1684380c25764637798b585b32287c4bcfc0f2014a78b7019547405e7ded SHA512 2ca25717c03385ae9bf879b8efeab8d508292d07f96d941032720d755d3db2e7bbc3c9a33c6103af9d83849ed8878bea1048d349bd0873288ee2addfee9756b7
-EBUILD sphinxcontrib-asyncio-0.2.0-r2.ebuild 1043 BLAKE2B 6d4a4cbedff93d24f4db0c6825836c49956dc1af74f77a19d779e748d121dca3e8877d6418829e0a214c95762a3af35b719745da1c5cd13ab6aa5da718ab7ff5 SHA512 c1640583a101489cbb5b409c981984c1a3007a7b967956751512e89ec404f3156e2e2c39b5deeff2a57a4b92db3ddc6f9830d3a8492468f9b172aa22a893fc33
+EBUILD sphinxcontrib-asyncio-0.2.0-r3.ebuild 908 BLAKE2B a6b3979a77ca6e00373cb1b6546e843657d195d23196033d892189754cbd686bf9e444bf931641baa21e51493b0f9bb9aca25956ca057302c58cacf63e0624d3 SHA512 592c3da169da3f3061b07d563515805dfca99bc90ee509d2ac251b959b8a888dd2ae53bd37d8b51253acff357273701ecdfb0ee43c7d3fcc02629f06457c63ec
MISC metadata.xml 397 BLAKE2B 357224874a9e2de147a2cc2a85350092fcd6189b1a3cb6cd1934c7eb922a9e0fb289776b65189dac007be1e663c3f98c73e656b5ab3677524bfac9329d41a542 SHA512 558c76f15358bb40e1c0a68750772487a3176b44f4f8ab046c0c8173d2fc0535516bd5dc4606646467785014a3e879ed7e31d5ccd10097741b02009c53042afe
diff --git a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r3.ebuild
index 16dca9b5330d..25f87bdc37e0 100644
--- a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
+++ b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r3.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
+
inherit distutils-r1
DESCRIPTION="sphinx extension to support coroutines in markup"
@@ -12,10 +14,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
distutils_enable_sphinx docs
@@ -27,13 +30,7 @@ src_prepare() {
default
}
-python_install() {
- rm "${BUILD_DIR}"/lib/sphinxcontrib/__init__.py || die
- distutils-r1_python_install --skip-build
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- # clean up pth files bug #623852
- find "${ED}" -name '*.pth' -delete || die
+python_compile() {
+ distutils-r1_python_compile
+ rm "${BUILD_DIR}/install$(python_get_sitedir)"/sphinxcontrib/__init__.py || die
}