summaryrefslogtreecommitdiff
path: root/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.8.0.ebuild')
-rw-r--r--dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.8.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.8.0.ebuild b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.8.0.ebuild
new file mode 100644
index 000000000000..d8c99b40ceb9
--- /dev/null
+++ b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="${PN//_/-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A reusable Ansible Sphinx theme"
+HOMEPAGE="https://github.com/ansible-community/sphinx_ansible_theme"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ doc? ( dev-python/ansible-pygments[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs 'dev-python/sphinx-notfound-page'
+
+S="${WORKDIR}"/${MY_P}