summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-prompt/sphinx-prompt-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-prompt/sphinx-prompt-1.5.0.ebuild')
-rw-r--r--dev-python/sphinx-prompt/sphinx-prompt-1.5.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/sphinx-prompt/sphinx-prompt-1.5.0.ebuild b/dev-python/sphinx-prompt/sphinx-prompt-1.5.0.ebuild
new file mode 100644
index 000000000000..ece6135668ec
--- /dev/null
+++ b/dev-python/sphinx-prompt/sphinx-prompt-1.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Sphinx directive to add unselectable prompt"
+HOMEPAGE="https://github.com/sbrunner/sphinx-prompt/"
+SRC_URI="https://github.com/sbrunner/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest