summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4-r1.ebuild')
-rw-r--r--dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4-r1.ebuild b/dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..434de8f770d1
--- /dev/null
+++ b/dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Add support for multiple versions to sphinx"
+HOMEPAGE="https://github.com/Holzhaus/sphinx-multiversion"
+SRC_URI="https://github.com/Holzhaus/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/alabaster