summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-gallery
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-gallery')
-rw-r--r--dev-python/sphinx-gallery/Manifest2
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.18.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 5fa62187dbd7..576beb675828 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1,3 +1,5 @@
DIST sphinx_gallery-0.17.1.tar.gz 464013 BLAKE2B 42a0d6e9fca934bfaf234710acc800229ee2dfc4844d17a5c1774ee5e36f6e2f1fe2a0f636035a58b4f2ea5bf0643abf9f018026a1d3b552093f1814c7f7cbe3 SHA512 7d580e3e603f6778dbf47e3f46ade2e612596337e432ee0ca5b603c7e002f43b65e0258dda04d427613b2a3331466b7c852287937c4706fe0bdafa1e7804f9fa
+DIST sphinx_gallery-0.18.0.tar.gz 466371 BLAKE2B 5d01bf19fa24d32ea667e7846dae03a85b470f430204a20d65efb988d54a8a6462e8cb6bed03de6f240c4945fbb1aa5e839d84feddd8093ab303d846773e4097 SHA512 59712e6a50d0a01e091b51e8532798ba4068a3a65472c25ea5a913dea599ac1afa54c44a057d332e6204930fa958d5b88dafe796af913566f504f0d9cf91e72a
EBUILD sphinx-gallery-0.17.1.ebuild 1462 BLAKE2B f3c640396bc9b01cced5bd5e7d6dfb85d509cf46242ccecb06f349480cc64231abbd9e06ea158a369f6d0169fe6387d24a3bbd2d5a1131a00e9111ef174906cd SHA512 66ec7ce0390ac5f4b621fd0677b86378da523b089a30822fe6f5f95bd82d8859d7f135e04fc0cf118334d8f414803de261e3c7078ecc9320b539697301e16ff4
+EBUILD sphinx-gallery-0.18.0.ebuild 1466 BLAKE2B b576ad0cd0fef8bdca5cadc14c91ea3c8ebf7969051ffd4e5f7f732d4234ef056c4a74f40db3910293dda941eb9919bd4ff63acaffb92cb2cd97fcfbd41642e1 SHA512 770d6373f8b4c37492c6ce4095b7e158c06a3e55a9206cabf692e7eedd64a57a4932fe65d2ae5205f33b191bebbdc594e866b6c5c84a6243a3c49a056c36d425
MISC metadata.xml 424 BLAKE2B 4e5cd1e912fd5934c7221d3e5cc60b2894eca6b994384f6ceb8397ce9c5312be1e9869b57f9dd7f3ac66501b20e6fd6abd2f33b5d19b93d3a12f7158ba08e7c6 SHA512 17acc19bf43dbbf1a377949576252f77fd334ddd8a3bec593d2339db5a44e4fde831f9ce47be97318bf72e30a062608f883e48cf572904b3476fde0df33adb09
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.18.0.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.18.0.ebuild
new file mode 100644
index 000000000000..5f967116b733
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.18.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="
+ https://github.com/sphinx-gallery/sphinx-gallery/
+ https://sphinx-gallery.github.io/
+ https://pypi.org/project/sphinx-gallery/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data
+ sphinx_gallery/tests/test_full.py::test_run_sphinx
+ sphinx_gallery/tests/test_full.py::test_embed_links_and_styles
+ # require jupyterlite_sphinx
+ sphinx_gallery/tests/test_full.py
+ sphinx_gallery/tests/test_full_noexec.py
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_non_default_contents
+ sphinx_gallery/tests/test_gen_gallery.py::test_create_jupyterlite_contents_with_jupyterlite_disabled_via_config
+ )
+
+ epytest -o addopts=
+}