summaryrefslogtreecommitdiff
path: root/dev-python/snakeoil/snakeoil-0.9.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/snakeoil/snakeoil-0.9.7.ebuild')
-rw-r--r--dev-python/snakeoil/snakeoil-0.9.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/snakeoil/snakeoil-0.9.7.ebuild b/dev-python/snakeoil/snakeoil-0.9.7.ebuild
new file mode 100644
index 000000000000..53cc9eba8f72
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.9.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD BSD-2 MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( >=dev-python/pytest-6 )"
+
+[[ ${PV} == 9999 ]] && BDEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest