summaryrefslogtreecommitdiff
path: root/dev-python/snakeoil/snakeoil-0.10.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/snakeoil/snakeoil-0.10.3.ebuild')
-rw-r--r--dev-python/snakeoil/snakeoil-0.10.3.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/snakeoil/snakeoil-0.10.3.ebuild b/dev-python/snakeoil/snakeoil-0.10.3.ebuild
deleted file mode 100644
index d2381d899739..000000000000
--- a/dev-python/snakeoil/snakeoil-0.10.3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
- inherit git-r3
-else
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-fi
-
-DESCRIPTION="misc common functionality and useful optimizations"
-HOMEPAGE="https://github.com/pkgcore/snakeoil"
-
-LICENSE="BSD BSD-2 MIT"
-SLOT="0"
-
-RDEPEND="
- dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/flit_core-3.8[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest