summaryrefslogtreecommitdiff
path: root/dev-python/smmap/smmap-0.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/smmap/smmap-0.9.0.ebuild')
-rw-r--r--dev-python/smmap/smmap-0.9.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/smmap/smmap-0.9.0.ebuild b/dev-python/smmap/smmap-0.9.0.ebuild
new file mode 100644
index 000000000000..f83353b0cc7a
--- /dev/null
+++ b/dev-python/smmap/smmap-0.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure git implementation of a sliding window memory map manager"
+HOMEPAGE="
+ https://pypi.org/project/smmap/
+ https://github.com/Byron/smmap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="amd64 ~arm64 x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nosexcover[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}