summaryrefslogtreecommitdiff
path: root/dev-python/slixmpp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/slixmpp')
-rw-r--r--dev-python/slixmpp/Manifest5
-rw-r--r--dev-python/slixmpp/files/slixmpp-1.7.1-fix-py3.10.patch28
-rw-r--r--dev-python/slixmpp/slixmpp-1.7.1.ebuild10
-rw-r--r--dev-python/slixmpp/slixmpp-9999.ebuild6
4 files changed, 37 insertions, 12 deletions
diff --git a/dev-python/slixmpp/Manifest b/dev-python/slixmpp/Manifest
index 681c7175939a..509fa85f25b5 100644
--- a/dev-python/slixmpp/Manifest
+++ b/dev-python/slixmpp/Manifest
@@ -1,4 +1,5 @@
+AUX slixmpp-1.7.1-fix-py3.10.patch 828 BLAKE2B 639e86be2d2289386ee782adfaf8fb05e6e994f21f65edf5bea552cc3838db440b753177fa3f4f76f200dabb6600618fbfdbdb8547d3e781a88d45c926a32b54 SHA512 1894d101d2d0afe6a59342e8aeffa530ab0a3732e18f0b7599b7abffcf559d0791f85cda9b5e87b181bd4c473ec3d88dee9be7be8c07c1e8db6943e18b000bf7
DIST slixmpp-1.7.1.tar.gz 931753 BLAKE2B 3de14be36353bc5f5f2cfbe002c44c5e843a7b36fa31a9dd315e363fc67e36d080df0dc70d82e65c6802c41377c2e98f56ff4e23cc5e9a92165c3d3b7565493f SHA512 5a59fcbb901e6f4456049f1ec2bbf781b1ec7c5a3ad4b66216d4c5daffa7f0606f74b941647fe2b53e6c8cdc476371305c7b7a2ca24d21450e19548f888be3b1
-EBUILD slixmpp-1.7.1.ebuild 792 BLAKE2B ac9f76de34858e5238a44ffcc16cbd3fd8f454ca916e2b2ceb997dbb35a3a54e1294f450458c95be02e9afb9b724973e7d2bb02660d87988a7b54cc556848ade SHA512 842725dc0d12d4fb4c05918dc6bc6e58fb50e3301328064eca0089c0f4302a3f3178b47a75ed3eebc77355dcfb84971137ec4ce97d200a69fab806bd60fcefed
-EBUILD slixmpp-9999.ebuild 793 BLAKE2B 63bf913e348b5b649dc53de6ad7a249f1424a54bdeef0efe8c8a50f84e59cf6283b93a92ae3cbdb737e01bae159dd9a6289f2538007a92944c8cbadd0735a05f SHA512 893d9ffb7e5ad08e27bf0b889c5688f1b1154f6912e1eea2f40086c84bdffd30a3c7443a93eeb636ca2b42fc9e9418ee73fe67b7116db2b5ef2d94ef50c2fb26
+EBUILD slixmpp-1.7.1.ebuild 757 BLAKE2B 396df75ba07ec319cf7301f00c5e8350299f7150270f01674112492f392678f65ce4690f7879df7332e2b9cc83f017826da4fa49fda2eed7327342d8d1267af7 SHA512 1bc48e432662641a7878fd8ef6b55821192b39f1217624a1a1ecf4b64508107c18e76a0b03895ecba9b5cd31c9c6df25d27a1764d24c21b5bf867855b0ad49e8
+EBUILD slixmpp-9999.ebuild 708 BLAKE2B a4ac98ff1a66305ce7e0e69b68d25653f66f9824f34233e78489f7240c07ed53e82325ca158ffa0f90b446dc2f5fbb9b4ec872b31630a477f089228fd72701ed SHA512 485664b264214d40aa3bc198d553c1fe093a281ee87ecf061282a2abda05a3a0d83ffa0d46bcbc62c08273a150cbf6d8ba6868df48d8842c7784878b6beb60ab
MISC metadata.xml 529 BLAKE2B 233dc2ff554368323e79fc11d7763b69d10e08a013789e19ad95c0ff2e7a392edbbde47f1811d69bf5b930824db4e399cb99d11dc90da2cf97c2347911c1f60f SHA512 8a6bf6d00fc0de5f3e12be9049ca25de2d866e5ef4352d9e1075676d9c6b66ecdee832b947a192b60832878be976666f131fab01627339a4f4406aa740ae4b25
diff --git a/dev-python/slixmpp/files/slixmpp-1.7.1-fix-py3.10.patch b/dev-python/slixmpp/files/slixmpp-1.7.1-fix-py3.10.patch
new file mode 100644
index 000000000000..0901090e4651
--- /dev/null
+++ b/dev-python/slixmpp/files/slixmpp-1.7.1-fix-py3.10.patch
@@ -0,0 +1,28 @@
+From 8b7648502b003d433a08333b041baf1d4960c9d4 Mon Sep 17 00:00:00 2001
+From: Nicolas Cedilnik <nicoco@nicoco.fr>
+Date: Mon, 22 Feb 2021 13:07:15 +0100
+Subject: [PATCH] Fix deprecation warning
+
+---
+ slixmpp/thirdparty/orderedset.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/slixmpp/thirdparty/orderedset.py b/slixmpp/thirdparty/orderedset.py
+index f6642db3..43023af4 100644
+--- a/slixmpp/thirdparty/orderedset.py
++++ b/slixmpp/thirdparty/orderedset.py
+@@ -20,9 +20,9 @@
+ # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+ # OTHER DEALINGS IN THE SOFTWARE.
+
+-import collections
++from collections.abc import MutableSet
+
+-class OrderedSet(collections.MutableSet):
++class OrderedSet(MutableSet):
+
+ def __init__(self, iterable=None):
+ self.end = end = []
+--
+GitLab
+
diff --git a/dev-python/slixmpp/slixmpp-1.7.1.ebuild b/dev-python/slixmpp/slixmpp-1.7.1.ebuild
index 19974e840958..e37f059d7d37 100644
--- a/dev-python/slixmpp/slixmpp-1.7.1.ebuild
+++ b/dev-python/slixmpp/slixmpp-1.7.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -31,8 +31,8 @@ RDEPEND="
${DEPEND}
"
-distutils_enable_tests unittest
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
-python_test() {
- "${EPYTHON}" ./run_tests.py || die "Tests failed with ${EPYTHON}"
-}
+distutils_enable_tests unittest
diff --git a/dev-python/slixmpp/slixmpp-9999.ebuild b/dev-python/slixmpp/slixmpp-9999.ebuild
index 0f5e88aa5f6c..4c7eb16a1e1b 100644
--- a/dev-python/slixmpp/slixmpp-9999.ebuild
+++ b/dev-python/slixmpp/slixmpp-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -32,7 +32,3 @@ RDEPEND="
"
distutils_enable_tests unittest
-
-python_test() {
- "${EPYTHON}" ./run_tests.py || die "Tests failed with ${EPYTHON}"
-}