summaryrefslogtreecommitdiff
path: root/dev-python/six/six-1.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/six/six-1.14.0.ebuild')
-rw-r--r--dev-python/six/six-1.14.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/six/six-1.14.0.ebuild b/dev-python/six/six-1.14.0.ebuild
new file mode 100644
index 000000000000..5b72b414e38a
--- /dev/null
+++ b/dev-python/six/six-1.14.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+distutils_enable_sphinx documentation
+distutils_enable_tests pytest