summaryrefslogtreecommitdiff
path: root/dev-python/sip
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest5
-rw-r--r--dev-python/sip/sip-6.8.6-r1.ebuild (renamed from dev-python/sip/sip-6.8.3.ebuild)22
2 files changed, 14 insertions, 13 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 728bdcbb3ef4..06197cdc452e 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,4 +1,3 @@
-DIST sip-6.8.3.gh.tar.gz 585528 BLAKE2B 2a58edba0f7ca9da02399df9fe71f152ef8446c38886ca2a21c00ef3ac65e0a82493a6047120d6f786e5b26f974c9cac24a329f1a52d9c47f9669afe2f0789b4 SHA512 6ff5fa59a55d71a3303553d2c53879fc9ccc01b9db34da149a7b81e252613327c7390c5a2edeaec03381dbc36ed38aa4ce44d69560c277ecc3875a57e7d75a60
-DIST sip-6.8.3.tar.gz 987656 BLAKE2B 57cc4010aae64eec7e0f338d9653463c7381b639aa8efca978a3f3296550a37b3a09b52933a2c2cd354a65155841952d7ca045b0b774945a382c29a8d597951e SHA512 8a0ff1c16ead4c2b1c53963a015fb3d149362f649eeec2523e6b243945493f28f5ecf29aabbf5cee5f7909ded40d64a1f469d2d0c1b3c33244e6213ab23ec733
-EBUILD sip-6.8.3.ebuild 855 BLAKE2B e5e4fbd847f5af0285b28877197babc57addcf6fc1a3bc823708b1e92e50bfd56490c5f5d676a685155cf20bb99e390c732ee7d580e2b91fae6d9979be4f0cb3 SHA512 57772b41d201d687a01ce2f55a871bfe62e2d122a2aecec2b895bc2bb5af8ddedf734acd7b229bd87e6d0bf24b00b09c8b73cb1e8346f617bd7a949e81c040cc
+DIST sip-6.8.6.gh.tar.gz 515751 BLAKE2B 769a1270351473f1c498e0d3cd463df3aa0992782b5501bd06455b71be05cae5a9754611bad4f966cc5b204170fec7fccbb065d9ed4c800daaa1bd6448a96352 SHA512 bfbeace21ef0bfd072548bcdb9af1f4917a33e15bcd9c5f6575aea0dc0eeaeec4aa322b2408f586c0e2713ada65c1657f81a4e0eb25cb9a3472fada234beca33
+EBUILD sip-6.8.6-r1.ebuild 849 BLAKE2B 985e254c4f7e7810541b7d792f378c855ce4433418e4f874eaabce3116f865cff5dcd6f2c2a40b58753aa11c8723004391a39dc85ded39f70e70bd7abf42429d SHA512 b6b2d4dc861857525a41029841fe15ef43c6097e5710ea5cfe411ead400d286a34af3053f1758b0790542f8d88a494ba304f3c716086dfe0552d182b978b4f1e
MISC metadata.xml 524 BLAKE2B 57657d01dc5be425f66f1136356fa028a32ad6a2ca79cadf4b9ed6a940b414b0e3efa161895d1858ab3d4977241883f9dfefbe37a8cbaad10589d57f598856a1 SHA512 82208b61b297d8c2110ea47a82c046118afd9332c52fa6590f7ed11b4e70af8b75f087b006fa5ed9058dbd2f98f02104559e085f781f2fc887396b7ff9d1b859
diff --git a/dev-python/sip/sip-6.8.3.ebuild b/dev-python/sip/sip-6.8.6-r1.ebuild
index e3cdc24f0a54..25b663e2221a 100644
--- a/dev-python/sip/sip-6.8.3.ebuild
+++ b/dev-python/sip/sip-6.8.6-r1.ebuild
@@ -5,27 +5,29 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} )
-inherit distutils-r1 pypi
+inherit distutils-r1
DESCRIPTION="Python bindings generator for C/C++ libraries"
HOMEPAGE="https://github.com/Python-SIP/sip/"
-# gh does not include a way to generate some files, so combine with pypi
-SRC_URI+="
- test? (
- https://github.com/Python-SIP/sip/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- )
+SRC_URI="
+ https://github.com/Python-SIP/sip/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
"
-LICENSE="|| ( GPL-2 GPL-3 SIP )"
+LICENSE="BSD-2 BSD"
SLOT="5"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
RDEPEND="
dev-python/packaging[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)
"
+BDEPEND="
+ >=dev-python/setuptools-scm-8[${PYTHON_USEDEP}]
+"
-distutils_enable_sphinx doc --no-autodoc
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme
distutils_enable_tests pytest