summaryrefslogtreecommitdiff
path: root/dev-python/sip/sip-6.8.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sip/sip-6.8.3.ebuild')
-rw-r--r--dev-python/sip/sip-6.8.3.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/sip/sip-6.8.3.ebuild b/dev-python/sip/sip-6.8.3.ebuild
index aaed5118beb9..5f9ffe71e07e 100644
--- a/dev-python/sip/sip-6.8.3.ebuild
+++ b/dev-python/sip/sip-6.8.3.ebuild
@@ -5,13 +5,16 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
-
inherit distutils-r1 pypi
DESCRIPTION="Python bindings generator for C/C++ libraries"
-HOMEPAGE="
- https://github.com/Python-SIP/sip/
- https://pypi.org/project/sip/
+HOMEPAGE="https://github.com/Python-SIP/sip/"
+# gh does not include a way to generate some files, so combine with pypi
+SRC_URI+="
+ test? (
+ https://github.com/Python-SIP/sip/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ )
"
LICENSE="|| ( GPL-2 GPL-3 SIP )"
@@ -25,3 +28,4 @@ RDEPEND="
"
distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest