summaryrefslogtreecommitdiff
path: root/dev-python/sip/sip-6.8.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sip/sip-6.8.3.ebuild')
-rw-r--r--dev-python/sip/sip-6.8.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sip/sip-6.8.3.ebuild b/dev-python/sip/sip-6.8.3.ebuild
new file mode 100644
index 000000000000..a1fec821017b
--- /dev/null
+++ b/dev-python/sip/sip-6.8.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)
+"
+
+distutils_enable_sphinx doc --no-autodoc