summaryrefslogtreecommitdiff
path: root/dev-python/simplejson/simplejson-3.18.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/simplejson/simplejson-3.18.4.ebuild')
-rw-r--r--dev-python/simplejson/simplejson-3.18.4.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/simplejson/simplejson-3.18.4.ebuild b/dev-python/simplejson/simplejson-3.18.4.ebuild
deleted file mode 100644
index fcb83a588896..000000000000
--- a/dev-python/simplejson/simplejson-3.18.4.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE="
- https://github.com/simplejson/simplejson/
- https://pypi.org/project/simplejson/
-"
-
-LICENSE="|| ( MIT AFL-2.1 )"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="+native-extensions"
-
-DOCS=( README.rst CHANGES.txt )
-
-distutils_enable_tests unittest
-
-src_configure() {
- export DISABLE_SPEEDUPS=$(usex native-extensions 0 1)
- use native-extensions && export REQUIRE_SPEEDUPS=1
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- eunittest
-}