summaryrefslogtreecommitdiff
path: root/dev-python/simplejson/simplejson-3.17.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/simplejson/simplejson-3.17.5.ebuild')
-rw-r--r--dev-python/simplejson/simplejson-3.17.5.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/simplejson/simplejson-3.17.5.ebuild b/dev-python/simplejson/simplejson-3.17.5.ebuild
new file mode 100644
index 000000000000..4eeb70ccbda3
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.17.5.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="https://github.com/simplejson/simplejson https://pypi.org/project/simplejson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest