summaryrefslogtreecommitdiff
path: root/dev-python/shapely/shapely-1.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/shapely/shapely-1.8.2.ebuild')
-rw-r--r--dev-python/shapely/shapely-1.8.2.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/shapely/shapely-1.8.2.ebuild b/dev-python/shapely/shapely-1.8.2.ebuild
deleted file mode 100644
index a437821df180..000000000000
--- a/dev-python/shapely/shapely-1.8.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Geometric objects, predicates, and operations"
-HOMEPAGE="
- https://pypi.org/project/Shapely/
- https://github.com/shapely/shapely/
-"
-SRC_URI="
- https://github.com/shapely/shapely/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-DEPEND="
- >=sci-libs/geos-3.9
-"
-RDEPEND="
- ${DEPEND}
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${DEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/matplotlib
-
-src_prepare() {
- rm -r _vendor || die
- sed -i -e 's:_vendor\.::' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- rm -rf shapely || die
- epytest
-}