summaryrefslogtreecommitdiff
path: root/dev-python/sexpdata/sexpdata-1.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sexpdata/sexpdata-1.0.2.ebuild')
-rw-r--r--dev-python/sexpdata/sexpdata-1.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/sexpdata/sexpdata-1.0.2.ebuild b/dev-python/sexpdata/sexpdata-1.0.2.ebuild
new file mode 100644
index 000000000000..1b50c712d956
--- /dev/null
+++ b/dev-python/sexpdata/sexpdata-1.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="a simple S-expression parser/serializer"
+HOMEPAGE="
+ https://github.com/jd-boyd/sexpdata/
+ https://pypi.org/project/sexpdata/
+"
+SRC_URI="
+ https://github.com/jd-boyd/sexpdata/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+distutils_enable_tests pytest