summaryrefslogtreecommitdiff
path: root/dev-python/sexpdata/sexpdata-0.0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sexpdata/sexpdata-0.0.3-r1.ebuild')
-rw-r--r--dev-python/sexpdata/sexpdata-0.0.3-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sexpdata/sexpdata-0.0.3-r1.ebuild b/dev-python/sexpdata/sexpdata-0.0.3-r1.ebuild
new file mode 100644
index 000000000000..5fec53a2f4fe
--- /dev/null
+++ b/dev-python/sexpdata/sexpdata-0.0.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit distutils-r1
+
+DESCRIPTION="a simple S-expression parser/serializer"
+HOMEPAGE="https://github.com/tkf/sexpdata"
+SRC_URI="https://github.com/tkf/sexpdata/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die
+}