summaryrefslogtreecommitdiff
path: root/dev-python/setuptools_scm/setuptools_scm-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/setuptools_scm/setuptools_scm-2.1.0.ebuild')
-rw-r--r--dev-python/setuptools_scm/setuptools_scm-2.1.0.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/dev-python/setuptools_scm/setuptools_scm-2.1.0.ebuild b/dev-python/setuptools_scm/setuptools_scm-2.1.0.ebuild
index 0367b5e4f012..82df58170f34 100644
--- a/dev-python/setuptools_scm/setuptools_scm-2.1.0.ebuild
+++ b/dev-python/setuptools_scm/setuptools_scm-2.1.0.ebuild
@@ -14,24 +14,25 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="git mercurial test"
+IUSE="test"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- git? ( dev-vcs/git )
- mercurial? ( dev-vcs/mercurial )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/mercurial )"
+
+python_prepare_all() {
+ # network access
+ sed -i -e 's:test_pip_download:_&:' testing/test_regressions.py || die
+ # all fetch specific setuptools versions
+ rm testing/test_setuptools_support.py || die
+
+ distutils-r1_python_prepare_all
+}
python_test() {
distutils_install_for_testing
- py.test -v -v -x -k testing/test_basic_api.py || die "tests failed under ${EPYTHON}"
- py.test -v -v -x -k testing/test_functions.py || die "tests failed under ${EPYTHON}"
- py.test -v -v -x -k testing/test_main.py || die "tests failed under ${EPYTHON}"
- py.test -v -v -x -k testing/test_regressions.py || die "tests failed under ${EPYTHON}"
- if use git; then
- py.test -v -v -x -k testing/test_git.py || die "tests failed under ${EPYTHON}"
- fi
- if use mercurial; then
- py.test -v -v -x -k testing/test_mercurial.py || die "tests failed under ${EPYTHON}"
- fi
+ py.test -v -v -x || die "Tests fail with ${EPYTHON}"
}