summaryrefslogtreecommitdiff
path: root/dev-python/setproctitle/setproctitle-1.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/setproctitle/setproctitle-1.2.2.ebuild')
-rw-r--r--dev-python/setproctitle/setproctitle-1.2.2.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/setproctitle/setproctitle-1.2.2.ebuild b/dev-python/setproctitle/setproctitle-1.2.2.ebuild
new file mode 100644
index 000000000000..81bb11e0f58d
--- /dev/null
+++ b/dev-python/setproctitle/setproctitle-1.2.2.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Allow customization of the process title"
+HOMEPAGE="https://github.com/dvarrazzo/py-setproctitle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests pytest