summaryrefslogtreecommitdiff
path: root/dev-python/serverfiles/serverfiles-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/serverfiles/serverfiles-0.2.1.ebuild')
-rw-r--r--dev-python/serverfiles/serverfiles-0.2.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/serverfiles/serverfiles-0.2.1.ebuild b/dev-python/serverfiles/serverfiles-0.2.1.ebuild
new file mode 100644
index 000000000000..5c1263570932
--- /dev/null
+++ b/dev-python/serverfiles/serverfiles-0.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6})
+inherit distutils-r1
+
+DESCRIPTION="Utility for accessing HTTP server and storing files locally for reuse"
+HOMEPAGE="https://github.com/biolab/serverfiles"
+SRC_URI="https://github.com/biolab/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/requests-2.11.1[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test(){
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}