summaryrefslogtreecommitdiff
path: root/dev-python/sentry-sdk
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest4
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.2.0.ebuild72
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.3.1.ebuild2
3 files changed, 2 insertions, 76 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 6e64f21e5dec..2d877fe1e4ed 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,5 +1,3 @@
-DIST sentry-sdk-1.2.0.tar.gz 218371 BLAKE2B dcba23b246d4620f93b82a07a9fa9c73ae8b67d54e9a690fc53c1b08580433b2d37a50f29a47e01c7cdcc29eef45cc0b67e96f1e9b333496002ceea5ce7388a9 SHA512 86705fab17331bf5cbe4dbb25562d80b5b080d2bee0a9bb2c153bb379e63ada10465bd5fdfa24d71fc50cc1d80d5afd3e569a779f2a11bde671cc6782ddca347
DIST sentry-sdk-1.3.1.tar.gz 219705 BLAKE2B 3fc8f81a5f762f400c70ae1c83ab46e97ec4641a61b86dc5b5a2cdbc22395b60fd53cef2d3d2dbfaaceb2d0bd32b842344fcaab898900b7dee2bd34ae3660f8b SHA512 60d819880b3d5316cad1ae4d236820f410c22c75c97d54d681f43ac6dfb503d3c5817314dd2db37107902b4e28d4f981ade200413388ecaf534135829723ef38
-EBUILD sentry-sdk-1.2.0.ebuild 2386 BLAKE2B fb8db9b507bfecd18b8ad697b7c75af6d5638bf6b957756badc40db23c5294c00274c2925270331d025d5a3afaef415b36faeca3262648e08a73f5657f70fe32 SHA512 93ae19cb5116c807af0e1b81f53ca9272cdc5670f058cd5bd668971fecd3f27061ce0faaca56fb0fee491aad8dd794bdda9c83fd4c81168fc370394e4ff6a303
-EBUILD sentry-sdk-1.3.1.ebuild 2390 BLAKE2B 13290e8d859fcf049d750e6ab6c1733b0f7de4bf262da72add049ff0cdc15c80fbb39c2dc013b9842b8d88f016a6226525e3a2d3ae780a1b706b599406184f84 SHA512 4f71b184eb7069a9851222b873172e4c065dc0f6377995a7d30ffbaefea7efc23ac12b999d3c0fe5652060131bd99cf5fc1b4f0703593d66af262553dda20a17
+EBUILD sentry-sdk-1.3.1.ebuild 2386 BLAKE2B fb8db9b507bfecd18b8ad697b7c75af6d5638bf6b957756badc40db23c5294c00274c2925270331d025d5a3afaef415b36faeca3262648e08a73f5657f70fe32 SHA512 93ae19cb5116c807af0e1b81f53ca9272cdc5670f058cd5bd668971fecd3f27061ce0faaca56fb0fee491aad8dd794bdda9c83fd4c81168fc370394e4ff6a303
MISC metadata.xml 509 BLAKE2B 5b68b368764625061ea2eadc0161570e46760904015f6e1e3e97a7a4dacd3604a18b2cbfb665e816981a40f95ec9c4f0c4a0447ecc968cbdf1fd21dcd4149193 SHA512 c42a1f7972313d3369ba392347b0efa700ee9c9b01d3275b3973b8137cf00fca693288a1af57c355b2d87525d9fcb7a320ad571fe8be5531472a8710f9b287d1
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.2.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.2.0.ebuild
deleted file mode 100644
index 0d827d4ea873..000000000000
--- a/dev-python/sentry-sdk/sentry-sdk-1.2.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Python client for Sentry"
-HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
-SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/sentry-python-${PV}"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/executing[${PYTHON_USEDEP}]
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/fakeredis[${PYTHON_USEDEP}]
- dev-python/flask-login[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/zope-event[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # tests require Internet access
- tests/integrations/httpx/test_httpx.py
- tests/integrations/requests/test_requests.py
- tests/integrations/stdlib/test_httplib.py
- # wtf is it supposed to do?!
- tests/integrations/gcp/test_gcp.py
- # hangs
- 'tests/test_transport.py::test_transport_works[eventlet'
- # TODO
- 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
- tests/test_client.py::test_databag_depth_stripping
- tests/test_client.py::test_databag_string_stripping
- tests/test_client.py::test_databag_breadth_stripping
- # incompatible version?
- tests/integrations/falcon/test_falcon.py
- # test_circular_references: apparently fragile
- 'tests/integrations/threading/test_threading.py::test_circular_references'
- # test for new feature, fails with IndexError
- tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
- )
-
- # Prevent tests/integrations/modules/test_modules.py:test_basic failure
- # Needs to detect sentry-sdk in the installed modules
- distutils_install_for_testing
-
- epytest ${deselect[@]/#/--deselect }
-}
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.3.1.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.3.1.ebuild
index d0881dad90d7..0d827d4ea873 100644
--- a/dev-python/sentry-sdk/sentry-sdk-1.3.1.ebuild
+++ b/dev-python/sentry-sdk/sentry-sdk-1.3.1.ebuild
@@ -13,7 +13,7 @@ S="${WORKDIR}/sentry-python-${PV}"
LICENSE="PSF-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
RDEPEND="
dev-python/urllib3[${PYTHON_USEDEP}]