summaryrefslogtreecommitdiff
path: root/dev-python/seaborn/seaborn-0.13.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/seaborn/seaborn-0.13.1.ebuild')
-rw-r--r--dev-python/seaborn/seaborn-0.13.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/seaborn/seaborn-0.13.1.ebuild b/dev-python/seaborn/seaborn-0.13.1.ebuild
new file mode 100644
index 000000000000..c377b54e8c4a
--- /dev/null
+++ b/dev-python/seaborn/seaborn-0.13.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Statistical data visualization"
+HOMEPAGE="
+ https://seaborn.pydata.org/
+ https://github.com/mwaskom/seaborn/
+ https://pypi.org/project/seaborn/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/matplotlib-3.4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.2[${PYTHON_USEDEP}]
+ >=dev-python/statsmodels-0.12[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.7[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_test() {
+ cat > matplotlibrc <<- EOF || die
+ backend : Agg
+ EOF
+
+ distutils-r1_src_test
+}