summaryrefslogtreecommitdiff
path: root/dev-python/seaborn/seaborn-0.10.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/seaborn/seaborn-0.10.1.ebuild')
-rw-r--r--dev-python/seaborn/seaborn-0.10.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/seaborn/seaborn-0.10.1.ebuild b/dev-python/seaborn/seaborn-0.10.1.ebuild
deleted file mode 100644
index 7b4da3c7d23c..000000000000
--- a/dev-python/seaborn/seaborn-0.10.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Statistical data visualization"
-HOMEPAGE="https://seaborn.pydata.org https://github.com/mwaskom/seaborn"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- <dev-python/matplotlib-3.3.0[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.22.0[${PYTHON_USEDEP}]
- dev-python/patsy[${PYTHON_USEDEP}]
- dev-python/statsmodels[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.0.1[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- cat > matplotlibrc <<- EOF || die
- backend : Agg
- EOF
- pytest -vv || die
-}