summaryrefslogtreecommitdiff
path: root/dev-python/scipy/scipy-1.10.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scipy/scipy-1.10.1.ebuild')
-rw-r--r--dev-python/scipy/scipy-1.10.1.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/dev-python/scipy/scipy-1.10.1.ebuild b/dev-python/scipy/scipy-1.10.1.ebuild
index 1b507dba0eb7..fbe608eae076 100644
--- a/dev-python/scipy/scipy-1.10.1.ebuild
+++ b/dev-python/scipy/scipy-1.10.1.ebuild
@@ -74,18 +74,6 @@ BDEPEND="
)
"
-EPYTEST_DESELECT=(
- linalg/tests/test_decomp.py::TestSchur::test_sort
- linalg/tests/test_solvers.py::test_solve_discrete_are
- optimize/tests/test_milp.py::test_milp_timeout_16545
-
- # Network
- datasets/tests/test_data.py::TestDatasets::test_existence_all
- datasets/tests/test_data.py::TestDatasets::test_ascent
- datasets/tests/test_data.py::TestDatasets::test_face
- datasets/tests/test_data.py::TestDatasets::test_electrocardiogram
-)
-
distutils_enable_tests pytest
src_unpack() {
@@ -107,6 +95,19 @@ python_configure_all() {
python_test() {
cd "${T}" || die
+ local EPYTEST_DESELECT=(
+ linalg/tests/test_decomp.py::TestSchur::test_sort
+ linalg/tests/test_solvers.py::test_solve_discrete_are
+ optimize/tests/test_milp.py::test_milp_timeout_16545
+
+ # Network
+ datasets/tests/test_data.py::TestDatasets::test_existence_all
+ datasets/tests/test_data.py::TestDatasets::test_ascent
+ datasets/tests/test_data.py::TestDatasets::test_face
+ datasets/tests/test_data.py::TestDatasets::test_electrocardiogram
+ )
+ local EPYTEST_IGNORE=()
+
if ! has_version -b "dev-python/pooch[${PYTHON_USEDEP}]" ; then
EPYTEST_IGNORE+=(
datasets/tests/test_data.py