summaryrefslogtreecommitdiff
path: root/dev-python/scikit-build
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scikit-build')
-rw-r--r--dev-python/scikit-build/Manifest2
-rw-r--r--dev-python/scikit-build/scikit-build-0.12.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/scikit-build/Manifest b/dev-python/scikit-build/Manifest
index d1c936f67763..bfd7d7204df1 100644
--- a/dev-python/scikit-build/Manifest
+++ b/dev-python/scikit-build/Manifest
@@ -1,5 +1,7 @@
AUX scikit-build-0.10.0-docs.patch 773 BLAKE2B 27303cb8ff439dbf9e44454ed58cffc2cbba53fd639b830e03707fce7aca0749018caac72891c3efa0b66b3830001634ca9e2cd34c769f625d2f735f5c1d4dcd SHA512 d6920e22ec20feec99768d09b3a01244eb6bf079b4d68c0eda1a17d04c640c7b5df6685c883812e7c9bf5455d6c5a8248a503f466db23da82d45b5ba53188252
AUX scikit-build-0.11.1-py310.patch 915 BLAKE2B 8ae5eb217482f0dfbcf966bbee65e9e2e2d7e74bff1970b6417789ca5c93881958640213ffe6c496a4a7f6578101fb51976528474cb3c8147302ec9221d9d1be SHA512 98bac74f6715320666be75455515efe35b208bc26209323453589cfb0c83ece5acefcaa5d17f625dd9ebb5970c06a3ba69334d140525d6b944066e50efdce22e
DIST scikit-build-0.11.1.tar.gz 132025 BLAKE2B 0f818d8da896695ee0d6b046249e74cbd4ea643bec0515d6ac6ff4276d92430a1dbf81abb3b7c10890538c373225a45cc21b0906de891f1a5390226be914dacd SHA512 030c6cc727d39cbafd2865722de9c45ba2f13461461cf75019b9caf6afd0a776b4f598fa2ce102b5adbc770140ab1de2c33e2bbd3ef03c958ae8849e5fc26cb4
+DIST scikit-build-0.12.0.tar.gz 138053 BLAKE2B 5007bd070cee14056cbc9cc24a022a39c920ce7fa794a79dcdb707f185529e1ed2442a201593f6df8d2dd9b4ab7a9a1ed209b0bc08f3feae748edd06894f8661 SHA512 76be92d8ff96dc230e38dc36a58021399dd8c57b6883dc032fbcd8f01ce42c879c6d557e7a46d48aa9b8bc724270f409f3760824d5810654b53a1aca25ec1cf9
EBUILD scikit-build-0.11.1.ebuild 1417 BLAKE2B 0877d71bb33439613b60fa747490cfac5898644d042d79966eeee192bc7133e0de6ad85c4e38405748d3f4c600c3d0d91356c4f4aeb23e494dfd09086c3e496d SHA512 24ceae6bef1bb7197571433d3adaf89feb021ed8c5a3ffb3994657d4c43a77e1fb38e76c09cf0d3785f1abc19cb9c7e02f1d6bb70dea5bba2d2cb56376f6d0b4
+EBUILD scikit-build-0.12.0.ebuild 1443 BLAKE2B 0e14fc8da9f3d9c98bc7ba81a91ab659975c3ea8cc36c7df69a5d2fa552655962d11026adffa92060a6788c0a4e5890eb12f57ed81b2cd53e2a798bd2430ab66 SHA512 9ee21ba07a5018b7e5a352cf5bc7b883ac344bca2f3c5fe032d0ceebcbac7864df109a0c4139bc3610710703f8254c1cba980a44d4a0a04a587d744dcf3f21be
MISC metadata.xml 407 BLAKE2B 91cafd558c8797a07a57e8581fe68b3353d6f70a00dbfda9ce1615fc5302f9cce23a806fc31f4359f670546a39a97ddd7958d0fd77ab6d18841f3888bdbda0c2 SHA512 2a06667260d774bf4e49553c709110b14e798cbe4641352c745c5af6e400bf027d1064997b5347e4ffadc27310dfe0bd02a58a891defd6d7cd96f1b2ed3909e0
diff --git a/dev-python/scikit-build/scikit-build-0.12.0.ebuild b/dev-python/scikit-build/scikit-build-0.12.0.ebuild
new file mode 100644
index 000000000000..18279621e56a
--- /dev/null
+++ b/dev-python/scikit-build/scikit-build-0.12.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Improved build system generator for Python C/C++/Fortran/Cython extensions"
+HOMEPAGE="https://github.com/scikit-build/scikit-build"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]"
+
+DEPEND="
+ test? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-issues
+distutils_enable_tests pytest
+
+src_prepare() {
+ # not packaged
+ sed -i -e '/cmakedomain/d' docs/conf.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local deselect=(
+ # sandbox violations
+ tests/test_hello_cpp.py::test_hello_develop
+ tests/test_issue274_support_default_package_dir.py
+ tests/test_issue274_support_one_package_without_package_dir.py
+ tests/test_issue334_configure_cmakelists_non_cp1252_encoding.py
+ )
+ epytest ${deselect[@]/#/--deselect }
+}